HIKVISION Kamera: Format HDD? Gerätefehler.

Beim Versuch ein ordentlich gemountetes NAS-Laufwerk zu formatieren, wirft die Kamera den Fehler: „Gerätefehler“.

Die Lösung ist: das Laufwerk muss komplett leer sein. Das war es bei mir leider nicht. Es war ein testweise angelegter Ordner und der vom NAS angelegte Papierkorb drauf. Beide entfernt und den Papierkorb des NAS entfernt und schon lässt sich formatieren….

HIKVISION: Fehler beim Installationsverzeichnis des NAS-Servers

Die Meldung: „Fehler beim Installationsverzeichnis des NAS-Servers; Ungültiges Verzeichnis“ wirft bei mir die HIKVISION DS-2CD2042WD-I wenn man versucht unter „Konfiguration / Speicherverwaltung / Netzlaufwerk“ ein NAS-Laufwerk per SMB anzubinden.

Das Web und seine Foren brachten mich nicht so richtig weiter, also habe ich experimentiert. Folgendes hat bei mir gut funktioniert:

  1. NAS-Laufwerksfreigabe mit einer Quota versehen. Ich habe 500 GB genommen. Anscheinend kann ohne Quota die Kamera ansonsten nicht die Größe der NAS-Laufwerksfreigabe ermitteln, bzw. die könnte bei großen Speicherkapazitäten über dem liegen, was die Kamera adressieren kann. Die o.a. Größe schluckt die Kamera aber problemlos. Größere Kapazitäten habe ich nicht getestet.
  2. Username der Freigabe scheint unkritisch zu sein. Hier habe ich sogar mit Sonderzeichen und einer gewissen Länge keine Probleme gehabt.
  3. Vorsicht aber beim Passwort. Dieses sollte offensichtlich nicht zu lang sein. Zumindest brachte bei der Verzicht auf:
    1. Sonderzeichen
    2. Nicht länger als 8 Zeichen

den entscheidenden Durchbruch.

Hoffe das hilft.

 

Bezeichnung der Netzwerkschnittstellen unter Ubuntu von z.B. „enp0s25“ oder „ens33“ umstellen auf „eth0“

Ubuntu benennt seit 16.04. die Netzwerkschnittstellen anders. Die Bezeichnungen können dabei z.B. lauten „enp0s25“ oder „ens33“ es gehen aber auch andere Namen, da Ubuntu die Karte nach einem Schema benennt, welches auf die Hardwareumgebung des jeweiligen Rechners zurückgreift. So bezeichnet etwa „enp0s25“ den PCI-Bus „0“ Slot „25“.

Ich finde dies weitgehend unpraktisch, gerade wenn man Skripte erstellt hat, die z.B. auf das „alte eth0“ zurückgreifen. All dies funktioniert dann nicht mehr.

Wie kann man die neue Bezeichnung nun wieder auf das alte „ethX“ umstellen?

Folgende Schritte:

  1. $ sudo nano /etc/default/grub
  2. In der Zeile „GRUB_CMDLINE_LINUX“ folgendes hinzufügen:
    GRUB_CMDLINE_LINUX=“net.ifnames=0 biosdevname=0″
  3. Danach GRUB neu konfigurieren:
    $ sudo grub-mkconfig -o /boot/grub/grub.cfg
  4. Nicht vergessen unter: /etc/network/interfaces die passenden Bezeichnungen entsprechend auf eth0, eth1, etc. abzuändern……
  5. $ sudo reboot

Fertig. Den Erfolg der ganzen Aktion kann man nach einem Reboot kontrollieren mit z.B.:

$ ip a

oder

$ ifconfig